Back to overview
Degraded
Delay in real-time payroll calculations
May 4, 2026 at 4:12pm UTC
Affected services
api.nmbr.co
Resolved
May 6, 2026 at 6:01pm UTC
Continuing to monitor as system return to normal
Affected services
Updated
May 5, 2026 at 8:38pm UTC
We have rolled back some underlying dependencies that may have contributed to the delay. The team is continuing to monitor the situation.
Affected services
Created
May 4, 2026 at 4:12pm UTC
We are investigating reports of delayed real-time payroll calculations
Affected services